What’s Vulnerable › Vulnerabilities
CVE-2026-24894: FrankenPHP leaks session data between requests in worker mode
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-12 · updated 2026-06-17
- Weakness: CWE-269
Description
FrankenPHP is a modern application server for PHP. Prior to 1.11.2, when running FrankenPHP in worker mode, the $_SESSION superglobal is not correctly reset between requests. This allows a subsequent request processed by the same worker to access the $_SESSION data of the previous request (potentially belonging to a different user) before session_start() is called. This vulnerability is fixed in 1.11.2.
Affected products
- php frankenphp: before 1.11.2 — fixed in 1.11.2
How to fix
Upgrade to a fixed version: php frankenphp 1.11.2. Check the vendor advisory for mitigations.
References
- https://github.com/php/frankenphp/commit/24d6c991a7761b638190eb081deae258143e9735
- https://github.com/php/frankenphp/releases/tag/v1.11.2
- https://github.com/php/frankenphp/security/advisories/GHSA-r3xh-3r3w-47gp
Get alerted when CVE-2026-24894 or the next vulnerability affects your stack