What’s Vulnerable › Vulnerabilities
CVE-2026-24896: OpenEMR has Broken Access Control that allows unauthorized access to EDI Logs
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-284
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to version 8.0.0, a Broken Access Control vulnerability exists in OpenEMR’s edih_main.php endpoint, which allows any authenticated user—including low-privilege roles like Receptionist—to access EDI log files by manipulating the log_select parameter in a GET request. The back-end fails to enforce role-based access control (RBAC), allowing sensitive system logs to be accessed outside the GUI-enforced permission boundaries. Version 8.0.0 fixes the issue.
Affected products
- openemr: before 8.0.0 — fixed in 8.0.0
How to fix
Upgrade to a fixed version: openemr 8.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/1a57dfc244b30e96e7ebdb5ba6f331a6eb868df1
- https://github.com/openemr/openemr/security/advisories/GHSA-rccq-vjfg-ggjh
Get alerted when CVE-2026-24896 or the next vulnerability affects your stack