What’s Vulnerable › Vulnerabilities
CVE-2026-24908: OpenEMR has SQL Injection in Patient API Sort Parameter
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-89
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to version 8.0.0, an SQL injection vulnerability in the Patient REST API endpoint allows authenticated users with API access to execute arbitrary SQL queries through the `_sort` parameter. This could potentially lead to database access, PHI (Protected Health Information) exposure, and credential compromise. The issue occurs when user-supplied sort field names are used in ORDER BY clauses without proper validation or identifier escaping. Version 8.0.0 fixes the issue.
Affected products
- openemr: before 8.0.0 — fixed in 8.0.0
How to fix
Upgrade to a fixed version: openemr 8.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/943e23cad6e979f87cdf168807fce2a7b32dd194
- https://github.com/openemr/openemr/security/advisories/GHSA-rcc2-45v3-qmqm
- https://github.com/openemr/openemr/security/advisories/GHSA-rcc2-45v3-qmqm
Get alerted when CVE-2026-24908 or the next vulnerability affects your stack