What’s Vulnerable › Vulnerabilities
CVE-2026-24910
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-27 · updated 2026-06-17
- Weakness: CWE-348
Description
In Bun before 1.3.5, the default trusted dependencies list (aka trust allow list) can be spoofed by a non-npm package in the case of a matching name (for file, link, git, or github).
Affected products
- Bun: before 1.3.5 — fixed in 1.3.5
How to fix
Upgrade to a fixed version: Bun 1.3.5. Check the vendor advisory for mitigations.
References
- https://bun.com/blog/bun-v1.3.5
- https://www.koi.ai/blog/packagegate-6-zero-days-in-js-package-managers-but-npm-wont-act
- https://www.scworld.com/news/six-javascript-zero-day-bugs-lead-to-fears-of-supply-chain-attack
Get alerted when CVE-2026-24910 or the next vulnerability affects your stack