What’s Vulnerable › Vulnerabilities

CVE-2026-24933: An improper certificate validation vulnerability was found in ADM while sending HTTPS requests to the server.

Description

The API communication component fails to validate the SSL/TLS certificate when sending HTTPS requests to the server. An improper certificates validation vulnerability allows an unauthenticated remote attacker can perform a Man-in-the-Middle (MitM) attack to intercept the cleartext communication, potentially leading to the exposure of sensitive user information, including account emails, MD5 hashed passwords, and device serial numbers. Affected products and versions include: from ADM 4.1.0 through ADM 4.3.3.ROF1 as well as from ADM 5.0.0 through ADM 5.1.1.RCI1.

Affected products

How to fix

Upgrade to a fixed version: Tenable ASUSTOR Data Master 5.1.2.re51. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-24933 or the next vulnerability affects your stack