What’s Vulnerable › Vulnerabilities
CVE-2026-25044: Budibase: Command Injection in Bash Automation Step
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-03 · updated 2026-10-06
- Weakness: CWE-78
Description
Budibase is an open-source low-code platform. Prior to version 3.33.4, the bash automation step executes user-provided commands using execSync without proper sanitization or validation. User input is processed through processStringSync which allows template interpolation, potentially allowing arbitrary command execution. This issue has been patched in version 3.33.4.
Affected products
- budibase: before 3.33.4 — fixed in 3.33.4
How to fix
Upgrade to a fixed version: budibase 3.33.4. Check the vendor advisory for mitigations.
References
- https://github.com/Budibase/budibase/releases/tag/3.33.2
- https://github.com/Budibase/budibase/security/advisories/GHSA-gjw9-34gf-rp6m
Get alerted when CVE-2026-25044 or the next vulnerability affects your stack