What’s Vulnerable › Vulnerabilities
CVE-2026-25060: OpenList Insecure TLS Default Configuration
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-02 · updated 2026-06-17
- Weakness: CWE-599
Description
OpenList Frontend is a UI component for OpenList. Prior to 4.1.10, certificate verification is disabled by default for all storage driver communications. The TlsInsecureSkipVerify setting is default to true in the DefaultConfig() function in internal/conf/config.go. This vulnerability enables Man-in-the-Middle (MitM) attacks by disabling TLS certificate verification, allowing attackers to intercept and manipulate all storage communications. Attackers can exploit this through network-level attacks like ARP spoofing, rogue Wi-Fi access points, or compromised internal network equipment to redirect traffic to malicious endpoints. Since certificate validation is skipped, the system will unknowingly establish encrypted connections with attacker-controlled servers, enabling full decryption, data theft, and manipulation of all storage operations without triggering any security warnings. This vulnerability is fixed in 4.1.10.
Affected products
- OpenListTeam OpenList: before 4.1.10 — fixed in 4.1.10
How to fix
Upgrade to a fixed version: OpenListTeam OpenList 4.1.10. Check the vendor advisory for mitigations.
References
- https://github.com/OpenListTeam/OpenList/commit/e3c664f81d0584fbbdb86ffe6644be16259371c1
- https://github.com/OpenListTeam/OpenList/releases/tag/v4.1.10
- https://github.com/OpenListTeam/OpenList/security/advisories/GHSA-wf93-3ghh-h389
Get alerted when CVE-2026-25060 or the next vulnerability affects your stack