What’s Vulnerable › Vulnerabilities
CVE-2026-25075: strongSwan 4.5.0 < 6.0.5 EAP-TTLS AVP Parsing Integer Underflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-23 · updated 2026-07-14
- Weakness: CWE-191
Description
strongSwan versions 4.5.0 prior to 6.0.5 contain an integer underflow vulnerability in the EAP-TTLS AVP parser that allows unauthenticated remote attackers to cause a denial of service by sending crafted AVP data with invalid length fields during IKEv2 authentication. Attackers can exploit the failure to validate AVP length fields before subtraction to trigger excessive memory allocation or NULL pointer dereference, crashing the charon IKE daemon.
Affected products
- strongSwan: from 4.5.0 before 6.0.5 — fixed in 6.0.5
How to fix
Upgrade to a fixed version: strongSwan 6.0.5. Check the vendor advisory for mitigations.
References
- https://www.strongswan.org/blog/2026/03/23/strongswan-6.0.5-released.html
- https://www.strongswan.org/blog/2026/03/23/strongswan-vulnerability-(cve-2026-25075).html
- https://www.vulncheck.com/advisories/strongswan-eap-ttls-avp-parsing-integer-underflow
- https://y637f9qq2x.com/posts/cve-2026-25075/
- https://lists.debian.org/debian-lts-announce/2026/03/msg00016.html
Get alerted when CVE-2026-25075 or the next vulnerability affects your stack