What’s Vulnerable › Vulnerabilities
CVE-2026-25116: Runtipi vulnerable to unauthenticated docker-compose.yml Overwrite via Path Traversal
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-29 · updated 2026-06-17
- Weakness: CWE-22
Description
Runtipi is a personal homeserver orchestrator. Starting in version 4.5.0 and prior to version 4.7.2, an unauthenticated Path Traversal vulnerability in the `UserConfigController` allows any remote user to overwrite the system's `docker-compose.yml` configuration file. By exploiting insecure URN parsing, an attacker can replace the primary stack configuration with a malicious one, resulting in full Remote Code Execution (RCE) and host filesystem compromise the next time the instance is restarted by the operator. Version 4.7.2 fixes the vulnerability.
Affected products
- runtipi: from 4.5.0 before 4.7.2 — fixed in 4.7.2
How to fix
Upgrade to a fixed version: runtipi 4.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/runtipi/runtipi/releases/tag/v4.7.2
- https://github.com/runtipi/runtipi/security/advisories/GHSA-mwg8-x997-cqw6
Get alerted when CVE-2026-25116 or the next vulnerability affects your stack