What’s Vulnerable › Vulnerabilities
CVE-2026-25128: fast-xml-parser has RangeError DoS Numeric Entities Bug
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-30 · updated 2026-06-17
- Weakness: CWE-20
Description
fast-xml-parser allows users to validate XML, parse XML to JS object, or build XML from JS object without C/C++ based libraries and no callback. In versions 5.0.9 through 5.3.3, a RangeError vulnerability exists in the numeric entity processing of fast-xml-parser when parsing XML with out-of-range entity code points (e.g., `�` or `�`). This causes the parser to throw an uncaught exception, crashing any application that processes untrusted XML input. Version 5.3.4 fixes the issue.
Affected products
- NaturalIntelligence fast-xml-parser: from 5.0.9 before 5.3.4 — fixed in 5.3.4
How to fix
Upgrade to a fixed version: NaturalIntelligence fast-xml-parser 5.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/NaturalIntelligence/fast-xml-parser/commit/4e387f61c4a5cef792f6a2f42467013290bf95dc
- https://github.com/NaturalIntelligence/fast-xml-parser/releases/tag/v5.3.4
- https://github.com/NaturalIntelligence/fast-xml-parser/security/advisories/GHSA-37qj-frw5-hhjh
Get alerted when CVE-2026-25128 or the next vulnerability affects your stack