What’s Vulnerable › Vulnerabilities
CVE-2026-25160: Alist has Insecure TLS Config
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-295
Description
Alist is a file list program that supports multiple storages, powered by Gin and Solidjs. Prior to version 3.57.0, the application disables TLS certificate verification by default for all outgoing storage driver communications, making the system vulnerable to Man-in-the-Middle (MitM) attacks. This enables the complete decryption, theft, and manipulation of all data transmitted during storage operations, severely compromising the confidentiality and integrity of user data. This issue has been patched in version 3.57.0.
Affected products
- AlistGo alist: before 3.57.0 — fixed in 3.57.0
How to fix
Upgrade to a fixed version: AlistGo alist 3.57.0. Check the vendor advisory for mitigations.
References
- https://github.com/AlistGo/alist/commit/69629ca76a8f2c8c973ede3b616f93aa26ff23fb
- https://github.com/AlistGo/alist/security/advisories/GHSA-8jmm-3xwx-w974
Get alerted when CVE-2026-25160 or the next vulnerability affects your stack