What’s Vulnerable › Vulnerabilities
CVE-2026-25161: Alist vulnerable to Path Traversal in multiple file operation handlers
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-22
Description
Alist is a file list program that supports multiple storages, powered by Gin and Solidjs. Prior to version 3.57.0, the application contains path traversal vulnerability in multiple file operation handlers. An authenticated attacker can bypass directory-level authorisation by injecting traversal sequences into filename components, enabling unauthorised file removal, movement and copying across user boundaries within the same storage mount. This issue has been patched in version 3.57.0.
Affected products
- AlistGo alist: before 3.57.0 — fixed in 3.57.0
How to fix
Upgrade to a fixed version: AlistGo alist 3.57.0. Check the vendor advisory for mitigations.
References
- https://github.com/AlistGo/alist/commit/b188288525b9a35c76535139311e7c036dab057e
- https://github.com/AlistGo/alist/security/advisories/GHSA-x4q4-7phh-42j9
Get alerted when CVE-2026-25161 or the next vulnerability affects your stack