What’s Vulnerable › Vulnerabilities
CVE-2026-25237: PEAR is Vulnerable to PHP Code Execution via preg_replace /e in Bug Update Emails
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-624
Description
PEAR is a framework and distribution system for reusable PHP components. Prior to version 1.33.0, use of preg_replace() with the /e modifier in bug update email handling can enable PHP code execution if attacker-controlled content reaches the evaluated replacement. This issue has been patched in version 1.33.0.
Affected products
- pearweb: before 1.33.0 — fixed in 1.33.0
How to fix
Upgrade to a fixed version: pearweb 1.33.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25237 or the next vulnerability affects your stack