What’s Vulnerable › Vulnerabilities
CVE-2026-25244: WebdriverIO has Command Injection in the BrowserStack Service
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-18 · updated 2026-07-24
- Weakness: CWE-78
Description
WebdriverIO is a test automation framework for unit, e2e and component testing using WebDriver, WebDriver BiDi and Appium. Versions below 9.24.0 contain a command injection vulnerability leading to remote code execution (RCE) in test orchestration. Git permits branch names containing shell metacharacters, and getGitMetadataForAISelection() interpolates these names directly into execSync() calls without sanitization. An attacker can exploit this by supplying a malicious repository (via testOrchestrationOptions.runSmartSelection.source, or the current directory if unset) whose branch name carries a payload, causing the shell to execute arbitrary code. This enables remote code execution on CI/CD servers and developer machines, leading to credential and secret disclosure, source code and SSH key exfiltration, system compromise, and supply chain attacks via tampered build artifacts. The issue has been fixed in version 9.24.0.
Affected products
- webdriverio: before 9.24.0 — fixed in 9.24.0
How to fix
Upgrade to a fixed version: webdriverio 9.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/webdriverio/webdriverio/blob/ea0e3e00288abced4c739ff9e46c46977b7cdbd2/packages/wdio-browserstack-service/src/testorchestration/helpers.ts#L204
- https://github.com/webdriverio/webdriverio/releases/tag/v9.24.0
- https://github.com/webdriverio/webdriverio/security/advisories/GHSA-5c46-x3qw-q7j7
- https://access.redhat.com/security/cve/CVE-2026-25244
- https://bugzilla.redhat.com/show_bug.cgi?id=2479692
- https://github.com/webdriverio/webdriverio/security/advisories/GHSA-5c46-x3qw-q7j7
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-25244.json
Get alerted when CVE-2026-25244 or the next vulnerability affects your stack