What’s Vulnerable › Vulnerabilities
CVE-2026-25498: Craft has a potential authenticated Remote Code Execution via malicious attached Behavior
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-09 · updated 2026-06-17
- Weakness: CWE-470
Description
Craft is a platform for creating digital experiences. In versions 4.0.0-RC1 through 4.16.17 and 5.0.0-RC1 through 5.8.21, a Remote Code Execution (RCE) vulnerability exists in Craft CMS where the assembleLayoutFromPost() function in src/services/Fields.php fails to sanitize user-supplied configuration data before passing it to Craft::createObject(). This allows authenticated administrators to inject malicious Yii2 behavior configurations that execute arbitrary system commands on the server. This vulnerability represents an unpatched variant of the behavior injection vulnerability addressed in CVE-2025-68455, affecting different endpoints through a separate code path. This vulnerability is fixed in 5.8.22.
Affected products
- craftcms cms: from 4.0.0 (excl.) before 4.16.18; from 5.0.0 (excl.) before 5.8.22; 4.0.0, 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3, 5.0.0, 5.0.0-rc1 — fixed in 4.16.18, 5.8.22
How to fix
Upgrade to a fixed version: craftcms cms 4.16.18, 5.8.22. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/commit/395c64f0b80b507be1c862a2ec942eaacb353748
- https://github.com/craftcms/cms/releases/tag/5.8.22
- https://github.com/craftcms/cms/security/advisories/GHSA-7jx7-3846-m7w7
Get alerted when CVE-2026-25498 or the next vulnerability affects your stack