What’s Vulnerable › Vulnerabilities
CVE-2026-25499: terraform-provider-proxmox has insecure sudo recommendation in the documentation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-22
Description
Terraform / OpenTofu Provider adds support for Proxmox Virtual Environment. Prior to version 0.93.1, in the SSH configuration documentation, the sudoer line suggested is insecure and can result in escaping the folder using ../, allowing any files on the system to be edited. This issue has been patched in version 0.93.1.
Affected products
- bpg terraform-provider-proxmox: before 0.93.1 — fixed in 0.93.1
How to fix
Upgrade to a fixed version: bpg terraform-provider-proxmox 0.93.1. Check the vendor advisory for mitigations.
References
- https://github.com/bpg/terraform-provider-proxmox/commit/bd604c41a31e2a55dd6acc01b0608be3ea49c023
- https://github.com/bpg/terraform-provider-proxmox/security/advisories/GHSA-gwch-7m8v-7544
- https://github.com/bpg/terraform-provider-proxmox/security/advisories/GHSA-gwch-7m8v-7544
Get alerted when CVE-2026-25499 or the next vulnerability affects your stack