What’s Vulnerable › Vulnerabilities
CVE-2026-25506: MUNGE has a buffer overflow in message unpacking allows key leakage and credential forgery
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-10 · updated 2026-07-15
- Weakness: CWE-787
Description
MUNGE is an authentication service for creating and validating user credentials. From 0.5 to 0.5.17, local attacker can exploit a buffer overflow vulnerability in munged (the MUNGE authentication daemon) to leak cryptographic key material from process memory. With the leaked key material, the attacker could forge arbitrary MUNGE credentials to impersonate any user (including root) to services that rely on MUNGE for authentication. The vulnerability allows a buffer overflow by sending a crafted message with an oversized address length field, corrupting munged's internal state and enabling extraction of the MAC subkey used for credential verification. This vulnerability is fixed in 0.5.18.
Affected products
- Debian Linux: 11.0
- openSUSE Munge: from 0.5 before 0.5.18 — fixed in 0.5.18
How to fix
Upgrade to a fixed version: openSUSE Munge 0.5.18. Check the vendor advisory for mitigations.
References
- https://github.com/dun/munge/commit/bf40cc27c4ce8451d4b062c9de0b67ec40894812
- https://github.com/dun/munge/releases/tag/munge-0.5.18
- https://github.com/dun/munge/security/advisories/GHSA-r9cr-jf4v-75gh
- http://www.openwall.com/lists/oss-security/2026/02/10/3
- http://www.openwall.com/lists/oss-security/2026/02/17/6
- https://lists.debian.org/debian-lts-announce/2026/02/msg00015.html
- https://access.redhat.com/errata/RHSA-2026:16174
- https://access.redhat.com/errata/RHSA-2026:2918
- https://access.redhat.com/errata/RHSA-2026:2923
- https://access.redhat.com/errata/RHSA-2026:2934
- https://access.redhat.com/errata/RHSA-2026:2949
- https://access.redhat.com/errata/RHSA-2026:2954
Get alerted when CVE-2026-25506 or the next vulnerability affects your stack