What’s Vulnerable › Vulnerabilities
CVE-2026-25510: CI4MS Vulnerable to Remote Code Execution (RCE) via Arbitrary File Creation and Save in File Editor
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-94
Description
CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.28.5.0, an authenticated user with file editor permissions can achieve Remote Code Execution (RCE) by leveraging the file creation and save endpoints, an attacker can upload and execute arbitrary PHP code on the server. This issue has been patched in version 0.28.5.0.
Affected products
- ci4-cms-erp ci4ms: before 0.28.5.0 — fixed in 0.28.5.0
How to fix
Upgrade to a fixed version: ci4-cms-erp ci4ms 0.28.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/ci4-cms-erp/ci4ms/commit/86be2930d1c54eb7575102563302b2f3bafcb653
- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-gp56-f67f-m4px
Get alerted when CVE-2026-25510 or the next vulnerability affects your stack