What’s Vulnerable › Vulnerabilities
CVE-2026-25514: FacturaScripts has SQL Injection vulnerability in Autocomplete Actions
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-20
Description
FacturaScripts is open-source enterprise resource planning and accounting software. Prior to version 2025.81, FacturaScripts contains a critical SQL injection vulnerability in the autocomplete functionality that allows authenticated attackers to extract sensitive data from the database including user credentials, configuration settings, and all stored business data. The vulnerability exists in the CodeModel::all() method where user-supplied parameters are directly concatenated into SQL queries without sanitization or parameterized binding. This issue has been patched in version 2025.81.
Affected products
- NeoRazorX facturascripts: before 2025.81 — fixed in 2025.81
How to fix
Upgrade to a fixed version: NeoRazorX facturascripts 2025.81. Check the vendor advisory for mitigations.
References
- https://github.com/NeoRazorX/facturascripts/commit/5c070f82665b98efd2f914a4769c6dc9415f5b0f
- https://github.com/NeoRazorX/facturascripts/security/advisories/GHSA-pqqg-5f4f-8952
Get alerted when CVE-2026-25514 or the next vulnerability affects your stack