What’s Vulnerable › Vulnerabilities
CVE-2026-25519: OpenSlides has incorrect access control vulnerability in authentication service
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-284
Description
OpenSlides is a free, web based presentation and assembly system for managing and projecting agenda, motions and elections of an assembly. Prior to version 4.2.29, OpenSlides supports local logins with username and password or an optionally configurable single sign on with SAML via an external IDP. For users synced to OpenSlides via an external IDP, there is an incorrect access control regarding the local login of these users. Users can successfully login using the local login form and the OpenSlides username of a SAML user and a trivial password. This password is valid for all SAML users. This issue has been patched in version 4.2.29.
Affected products
- Intevation OpenSlides: from 4.2.5 before 4.2.29 — fixed in 4.2.29
How to fix
Upgrade to a fixed version: Intevation OpenSlides 4.2.29. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSlides/OpenSlides/releases/tag/4.2.29
- https://github.com/OpenSlides/OpenSlides/security/advisories/GHSA-vv4h-8wfc-pf8c
- https://github.com/OpenSlides/openslides-auth-service/commit/70c1aa9f5e1db59ec120ecce98d1c1169350a4ee
- https://github.com/OpenSlides/openslides-auth-service/pull/889
Get alerted when CVE-2026-25519 or the next vulnerability affects your stack