What’s Vulnerable › Vulnerabilities
CVE-2026-25529: Postal has HTML injection / XSS in message view
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Postal is an open source SMTP server. Postal versions less than 3.3.5 had a HTML injection vulnerability that allowed unescaped data to be included in the admin interface. The primary way for unescaped data to be added is via the API's "send/raw" method. This could allow arbitrary HTML to be injected in to the page which may modify the page in a misleading way or allow for unauthorised javascript to be executed. Fixed in 3.3.5 and higher.
Affected products
- postalserver postal: before 3.3.5 — fixed in 3.3.5
How to fix
Upgrade to a fixed version: postalserver postal 3.3.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25529 or the next vulnerability affects your stack