What’s Vulnerable › Vulnerabilities
CVE-2026-25554: OpenSIPS 3.1 <= 3.6.4 auth_jwt SQL Injection Enables JWT Authentication Bypass
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-25 · updated 2026-07-14
- Weakness: CWE-89
Description
OpenSIPS versions 3.1 before 3.6.4 containing the auth_jwt module (prior to commit 3822d33) contain a SQL injection vulnerability in the jwt_db_authorize() function in modules/auth_jwt/authorize.c when db_mode is enabled and a SQL database backend is used. The function extracts the tag claim from a JWT without prior signature verification and incorporates the unescaped value directly into a SQL query. An attacker can supply a crafted JWT with a malicious tag claim to manipulate the query result and bypass JWT authentication, allowing impersonation of arbitrary identities.
Affected products
- opensips: from 3.1 before 3.6.4 — fixed in 3.6.4
How to fix
Upgrade to a fixed version: opensips 3.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSIPS/opensips/commit/3822d33c1c6b25832fdd88da1d23eed74be55b05
- https://github.com/OpenSIPS/opensips/pull/3807
- https://opensips.org/
- https://opensips.org/pub/opensips/3.6.4/ChangeLog
- https://www.vulncheck.com/advisories/opensips-auth-jwt-sql-injection-enables-jwt-authentication-bypass
Get alerted when CVE-2026-25554 or the next vulnerability affects your stack