What’s Vulnerable › Vulnerabilities
CVE-2026-25570
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-121
Description
A vulnerability has been identified in SICAM SIAPP SDK (All versions < V2.1.7). The SICAM SIAPP SDK does not perform checks on input values potentially resulting in stack overflow. This could allow an attacker to perform code execution and denial of service.
Affected products
- Siemens SICAM SIAPP SDK: before 2.17 — fixed in 2.17
How to fix
Upgrade to a fixed version: Siemens SICAM SIAPP SDK 2.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25570 or the next vulnerability affects your stack