What’s Vulnerable › Vulnerabilities
CVE-2026-25609: profile command may permit unauthorized configuration
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-10 · updated 2026-06-17
- Weakness: CWE-862
Description
Incorrect validation of the profile command may result in the determination that a request altering the 'filter' is read-only.
Affected products
- MongoDB: from 7.0.0 before 7.0.29; from 8.0.0 before 8.0.18; from 8.2.0 before 8.2.4 — fixed in 7.0.29, 8.0.18, 8.2.4
How to fix
Upgrade to a fixed version: MongoDB 7.0.29, 8.0.18, 8.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25609 or the next vulnerability affects your stack