What’s Vulnerable › Vulnerabilities
CVE-2026-25610: Invalid $geoNear index hint may cause server crash
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-10 · updated 2026-06-17
- Weakness: CWE-617
Description
An authorized user may trigger a server crash by running a $geoNear pipeline with certain invalid index hints.
Affected products
- MongoDB: from 7.0.0 before 7.0.29; from 8.0.0 before 8.0.13 — fixed in 7.0.29, 8.0.13
How to fix
Upgrade to a fixed version: MongoDB 7.0.29, 8.0.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25610 or the next vulnerability affects your stack