What’s Vulnerable › Vulnerabilities
CVE-2026-25611: Pre-Authentication Memory Exhaustion Denial of Service in MongoDB Server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-10 · updated 2026-06-17
- Weakness: CWE-405
Description
A series of specifically crafted, unauthenticated messages can exhaust available memory and crash a MongoDB server.
Affected products
- MongoDB: from 8.2 before 8.2.4; from 8.0 before 8.0.18; from 7.0 before 7.0.29 — fixed in 7.0.29, 8.0.18, 8.2.4
How to fix
Upgrade to a fixed version: MongoDB 7.0.29, 8.0.18, 8.2.4. Check the vendor advisory for mitigations.
References
- https://jira.mongodb.org/browse/SERVER-116206
- https://jira.mongodb.org/browse/SERVER-116210
- https://jira.mongodb.org/browse/SERVER-116211
Get alerted when CVE-2026-25611 or the next vulnerability affects your stack