What’s Vulnerable › Vulnerabilities
CVE-2026-25613: An unsafe cast in the MongoDB query planner can result in a segmentation fault.
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-10 · updated 2026-06-17
- Weakness: CWE-704
Description
An authorized user may disable the MongoDB server by issuing a query against a collection that contains an invalid compound wildcard index.
Affected products
- MongoDB: from 7.0.0 before 7.0.29; from 8.0.0 before 8.0.18; from 8.2.0 before 8.2.4 — fixed in 7.0.29, 8.0.18, 8.2.4
How to fix
Upgrade to a fixed version: MongoDB 7.0.29, 8.0.18, 8.2.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25613 or the next vulnerability affects your stack