What’s Vulnerable › Vulnerabilities
CVE-2026-25688: Apache Answer: XSS in AI Answer Rendering
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-87
Description
Improper Neutralization of Alternate XSS Syntax vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. AI-generated response content was rendered in the browser without proper sanitization, allowing malicious scripts to be executed when the content was viewed. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Answer: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Answer 2.0.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/x42joj43rqb38ms5q60f7bgq3qbo7t5q
- http://www.openwall.com/lists/oss-security/2026/06/09/7
Get alerted when CVE-2026-25688 or the next vulnerability affects your stack