What’s Vulnerable › Vulnerabilities
CVE-2026-25699: Apache Answer: Authorization Bypass in Timeline API
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-359
Description
Exposure of Private Personal Information to an Unauthorized Actor vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. Timeline-related APIs lacked proper authorization checks, allowing regular authenticated users to access deleted, private, or unapproved content and its revision history. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Answer: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Answer 2.0.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/c36k4hzwhncqo0qfn5fg57f1gkjhyfv8
- http://www.openwall.com/lists/oss-security/2026/06/09/6
Get alerted when CVE-2026-25699 or the next vulnerability affects your stack