What’s Vulnerable › Vulnerabilities
CVE-2026-25739: Indico affected by Cross-Site-Scripting via material uploads
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Versions prior to 3.3.10 are vulnerable to cross-site scripting when uploading certain file types as materials. Users should upgrade to version 3.3.10 to receive a patch. To apply the fix itself updating is sufficient, but to benefit from the strict Content Security Policy (CSP) Indico now applies by default for file downloads, update the webserver config in case one uses nginx with Indico's `STATIC_FILE_METHOD` set to `xaccelredirect`. For further directions, consult the GitHub Security advisory or Indico setup documentation. Some workarounds are available. Use the webserver config to apply a strict CSP for material download endpoints, and/or only let trustworthy users create content (including material uploads, which speakers can typically do as well) on Indico.
Affected products
- indico: before 3.3.10 — fixed in 3.3.10
How to fix
Upgrade to a fixed version: indico 3.3.10. Check the vendor advisory for mitigations.
References
- https://github.com/indico/indico/releases/tag/v3.3.10
- https://github.com/indico/indico/security/advisories/GHSA-jxc4-54g3-j7vp
Get alerted when CVE-2026-25739 or the next vulnerability affects your stack