What’s Vulnerable › Vulnerabilities
CVE-2026-25759: Statmatic affected by privilege escalation via stored cross-site scripting
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Statmatic is a Laravel and Git powered content management system (CMS). From 6.0.0 to before 6.2.3, a stored XSS vulnerability in content titles allows authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. Malicious user must have an account with control panel access and content creation permissions. This vulnerability can be exploited to allow super admin accounts to be created. This has been fixed in 6.2.3.
Affected products
- Statamic: from 6.0.0 before 6.2.3 — fixed in 6.2.3
How to fix
Upgrade to a fixed version: Statamic 6.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/statamic/cms/commit/6ed4f65f3387686d6dbd816e9b4f18a8d9736ff6
- https://github.com/statamic/cms/releases/tag/v6.2.3
- https://github.com/statamic/cms/security/advisories/GHSA-ff9r-ww9c-43x8
Get alerted when CVE-2026-25759 or the next vulnerability affects your stack