What’s Vulnerable › Vulnerabilities
CVE-2026-25767: LavinMQ has incomplete shovel configuration validation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-12 · updated 2026-06-17
- Weakness: CWE-863
Description
LavinMQ is a high-performance message queue & streaming server. Before 2.6.8, an authenticated user, with the “Policymaker” tag, could create shovels bypassing access controls. an authenticated user with the "Policymaker" management tag could exploit it to read messages from vhosts they are not authorized to access or publish messages to vhosts they are not authorized to access. This vulnerability is fixed in 2.6.8.
Affected products
- cloudamqp lavinmq: before 2.6.8 — fixed in 2.6.8
How to fix
Upgrade to a fixed version: cloudamqp lavinmq 2.6.8. Check the vendor advisory for mitigations.
References
- https://github.com/cloudamqp/lavinmq/commit/3a83e5894495b60c7c32a79c3dbc9bd9fa237d9a
- https://github.com/cloudamqp/lavinmq/commit/be03da31f3db1a2552f7094ff58e953ef50cdc82
- https://github.com/cloudamqp/lavinmq/pull/1670
- https://github.com/cloudamqp/lavinmq/pull/1687
- https://github.com/cloudamqp/lavinmq/security/advisories/GHSA-wh37-6vrr-r9wg
Get alerted when CVE-2026-25767 or the next vulnerability affects your stack