What’s Vulnerable › Vulnerabilities
CVE-2026-25797: ImageMagick vulnerable to Code injection via PostScript header in ps coders
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-94
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-15 and 6.9.13-40, the ps coders, responsible for writing PostScript files, fails to sanitize the input before writing it into the PostScript header. An attacker can provide a malicous file and inject arbitrary PostScript code. When the resulting file is processed by a printer or a viewer (like Ghostscript), the injected code is interpreted and executed. The html encoder does not properly escape strings that are written to in the html document. An attacker can provide a malicious file and injection arbitrary html code. Versions 7.1.2-15 and 6.9.13-40 contain a patch.
Affected products
- ImageMagick: before 6.9.13-40; from 7.0.0-0 before 7.1.2-15 — fixed in 6.9.13-40, 7.1.2-15
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-40, 7.1.2-15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25797 or the next vulnerability affects your stack