What’s Vulnerable › Vulnerabilities
CVE-2026-25802: New API has Potential XSS in its MarkdownRenderer component
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-79
Description
New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. Prior to version 0.10.8-alpha.9, a potential unsafe operation occurs in component `MarkdownRenderer.jsx`, allowing for Cross-Site Scripting(XSS) when the model outputs items containing `<script>` tag. Version 0.10.8-alpha.9 fixes the issue.
Affected products
- QuantumNous new-api: before 0.10.8; 0.10.8-alpha1, 0.10.8-alpha2, 0.10.8-alpha3, 0.10.8-alpha4, 0.10.8-alpha5, 0.10.8-alpha6 (+2) — fixed in 0.10.8
How to fix
Upgrade to a fixed version: QuantumNous new-api 0.10.8. Check the vendor advisory for mitigations.
References
- https://github.com/QuantumNous/new-api/commit/ab5456eb1049aa8a0f3e51f359907ec7fff38b4b
- https://github.com/QuantumNous/new-api/security/advisories/GHSA-299v-8pq9-5gjq
Get alerted when CVE-2026-25802 or the next vulnerability affects your stack