What’s Vulnerable › Vulnerabilities
CVE-2026-25859: WeKan < 8.20 Migration Functionality Insufficient Permission Checks
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-07 · updated 2026-07-14
- Weakness: CWE-863
Description
Wekan versions prior to 8.20 allow non-administrative users to access migration functionality due to insufficient permission checks, potentially resulting in unauthorized migration operations.
Affected products
- WeKan: before 8.20 — fixed in 8.20
How to fix
Upgrade to a fixed version: WeKan 8.20. Check the vendor advisory for mitigations.
References
- https://github.com/wekan/wekan/commit/cbb1cd78de3e40264a5e047ace0ce27f8635b4e6
- https://wekan.fi/
- https://www.vulncheck.com/advisories/wekan-migration-functionality-insufficient-permission-checks
Get alerted when CVE-2026-25859 or the next vulnerability affects your stack