What’s Vulnerable › Vulnerabilities
CVE-2026-25882: Fiber has a Denial of Service Vulnerability via Route Parameter Overflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-129
Description
Fiber is an Express inspired web framework written in Go. A denial of service vulnerability exists in Fiber v2 and v3 that allows remote attackers to crash the application by sending requests to routes with more than 30 parameters. The vulnerability results from missing validation during route registration combined with an unbounded array write during request matching. Version 2.52.12 patches the issue in the v2 branch and 3.1.0 patches the issue in the v3 branch.
Affected products
- gofiber fiber: from 2.0.0 before 2.52.12; from 3.0.0 before 3.1.0 — fixed in 2.52.12, 3.1.0
How to fix
Upgrade to a fixed version: gofiber fiber 2.52.12, 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/gofiber/fiber/blob/main/path.go#L514
- https://github.com/gofiber/fiber/blob/v2/path.go#L516
- https://github.com/gofiber/fiber/pull/3962
- https://github.com/gofiber/fiber/security/advisories/GHSA-mrq8-rjmw-wpq3
Get alerted when CVE-2026-25882 or the next vulnerability affects your stack