What’s Vulnerable › Vulnerabilities
CVE-2026-25888: Chartbrew: Remote Code Execution (RCE) via Vulnerable API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-06 · updated 2026-06-17
- Weakness: CWE-94
Description
Chartbrew is an open-source web application that can connect directly to databases and APIs and use the data to create charts. Prior to version 4.8.1, there is a remote code execution vulnerability via a vulnerable API. This issue has been patched in version 4.8.1.
Affected products
- chartbrew: before 4.8.1 — fixed in 4.8.1
How to fix
Upgrade to a fixed version: chartbrew 4.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/chartbrew/chartbrew/releases/tag/v4.8.1
- https://github.com/chartbrew/chartbrew/security/advisories/GHSA-875w-45c2-gxq8
Get alerted when CVE-2026-25888 or the next vulnerability affects your stack