What’s Vulnerable › Vulnerabilities
CVE-2026-25921: Gogs: Cross-repository LFS object overwrite via missing content hash verification
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-345
Description
Gogs is an open source self-hosted Git service. Prior to version 0.14.2, overwritable LFS object across different repos leads to supply-chain attack, all LFS objects are vulnerable to be maliciously overwritten by malicious attackers. This issue has been patched in version 0.14.2.
Affected products
- gogs: before 0.14.2 — fixed in 0.14.2
How to fix
Upgrade to a fixed version: gogs 0.14.2. Check the vendor advisory for mitigations.
References
- https://github.com/gogs/gogs/commit/81ee8836445ac888d99da8b652be7d5cbc5c4d5c
- https://github.com/gogs/gogs/pull/8166
- https://github.com/gogs/gogs/releases/tag/v0.14.2
- https://github.com/gogs/gogs/security/advisories/GHSA-cj4v-437j-jq4c
Get alerted when CVE-2026-25921 or the next vulnerability affects your stack