What’s Vulnerable › Vulnerabilities
CVE-2026-25924: Kanboard is Missing Access Control on Plugin Installation leading to Administrative RCE
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-11 · updated 2026-06-17
- Weakness: CWE-863
Description
Kanboard is project management software focused on Kanban methodology. Prior to 1.2.50, a security control bypass vulnerability in Kanboard allows an authenticated administrator to achieve full Remote Code Execution (RCE). Although the application correctly hides the plugin installation interface when the PLUGIN_INSTALLER configuration is set to false, the underlying backend endpoint fails to verify this security setting. An attacker can exploit this oversight to force the server to download and install a malicious plugin, leading to arbitrary code execution. This vulnerability is fixed in 1.2.50.
Affected products
- kanboard: before 1.2.50 — fixed in 1.2.50
How to fix
Upgrade to a fixed version: kanboard 1.2.50. Check the vendor advisory for mitigations.
References
- https://github.com/kanboard/kanboard/commit/b9ada89b1a64034612fc4262b88c42458c0d6ee4
- https://github.com/kanboard/kanboard/releases/tag/v1.2.50
- https://github.com/kanboard/kanboard/security/advisories/GHSA-grch-p7vf-vc4f
Get alerted when CVE-2026-25924 or the next vulnerability affects your stack