What’s Vulnerable › Vulnerabilities
CVE-2026-25957: Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-09 · updated 2026-06-17
- Weakness: CWE-755
Description
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
Affected products
- cube-js cube: from 1.1.17 before 1.4.2; from 1.5.0 before 1.5.13 — fixed in 1.4.2, 1.5.13
How to fix
Upgrade to a fixed version: cube-js cube 1.4.2, 1.5.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25957 or the next vulnerability affects your stack