What’s Vulnerable › Vulnerabilities
CVE-2026-25958: Cube privilege escalation via a specially crafted request
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-09 · updated 2026-06-17
- Weakness: CWE-807
Description
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
Affected products
- cube-js cube: from 0.27.19 before 1.0.14; from 1.1.0 before 1.4.2; from 1.5.0 before 1.5.13 — fixed in 1.0.14, 1.4.2, 1.5.13
How to fix
Upgrade to a fixed version: cube-js cube 1.0.14, 1.4.2, 1.5.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25958 or the next vulnerability affects your stack