What’s Vulnerable › Vulnerabilities
CVE-2026-25967: ImageMagick has stack buffer overflow in FTXT reader via oversized integer field
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-121
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-15, a stack-based buffer overflow exists in the ImageMagick FTXT image reader. A crafted FTXT file can cause out-of-bounds writes on the stack, leading to a crash. Version 7.1.2-15 contains a patch.
Affected products
- ImageMagick: before 6.9.13-40; from 7.0.0-0 before 7.1.2-15 — fixed in 6.9.13-40, 7.1.2-15
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-40, 7.1.2-15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25967 or the next vulnerability affects your stack