What’s Vulnerable › Vulnerabilities
CVE-2026-25970: ImageMagick SIXEL Decoder Has Signed Integer Overflow, Leading to Memory Corruption
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-190
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-15 and 6.9.13-40, a signed integer overflow vulnerability in ImageMagick's SIXEL decoder allows an attacker to trigger memory corruption and denial of service when processing a maliciously crafted SIXEL image file. The vulnerability occurs during buffer reallocation operations where pointer arithmetic using signed 32-bit integers overflows. Versions 7.1.2-15 and 6.9.13-40 contain a patch.
Affected products
- ImageMagick: before 6.9.13-40; from 7.0.0-0 before 7.1.2-15 — fixed in 6.9.13-40, 7.1.2-15
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-40, 7.1.2-15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25970 or the next vulnerability affects your stack