What’s Vulnerable › Vulnerabilities
CVE-2026-25971: ImageMagick's MSL: Stack overflow in ProcessMSLScript
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-674
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-15 and 6.9.13-40, Magick fails to check for circular references between two MSLs, leading to a stack overflow. Versions 7.1.2-15 and 6.9.13-40 contain a patch.
Affected products
- ImageMagick: before 6.9.13-40; from 7.0.0-0 before 7.1.2-15 — fixed in 6.9.13-40, 7.1.2-15
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-40, 7.1.2-15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-25971 or the next vulnerability affects your stack