What’s Vulnerable › Vulnerabilities
CVE-2026-26002: OnDemand susceptible to malicious input when navigating to a directory.
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-04 · updated 2026-06-17
- Weakness: CWE-74
Description
Open OnDemand is an open-source high-performance computing portal. The Files application in OnDemand versions prior to 4.0.9 and 4.1.3 is susceptible to malicious input when navigating to a directory. This has been patched in versions 4.0.9 and 4.1.3. Versions below this remain susceptible.
Affected products
- OSC ondemand: before 3.1.16; from 4.0.0 before 4.0.9; from 4.1.0 before 4.1.3 — fixed in 3.1.16, 4.0.9, 4.1.3
How to fix
Upgrade to a fixed version: OSC ondemand 3.1.16, 4.0.9, 4.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/OSC/ondemand/commit/23cb167222886fdd8415277ca5c1215f4c32629c
- https://github.com/OSC/ondemand/commit/37f0ae4efb222e9c0af250feae860a720427df16
- https://github.com/OSC/ondemand/security/advisories/GHSA-f83q-mhrr-3cr2
Get alerted when CVE-2026-26002 or the next vulnerability affects your stack