What’s Vulnerable › Vulnerabilities
CVE-2026-26003: FastGPT Plugin forwarding request is not authenticated, posing a serious risk of attack
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-10 · updated 2026-06-17
- Weakness: CWE-601
Description
FastGPT is an AI Agent building platform. From 4.14.0 to 4.14.5, attackers can directly access the plugin system through FastGPT/api/plugin/xxx without authentication, thereby threatening the plugin system. This may cause the plugin system to crash and the loss of plugin installation status, but it will not result in key leakage. For older versions, as there are only operation interfaces for obtaining information, the impact is almost negligible. This vulnerability is fixed in 4.14.5-fix.
Affected products
- labring FastGPT: from 4.14.0 before 4.14.5; 4.14.5 — fixed in 4.14.5
How to fix
Upgrade to a fixed version: labring FastGPT 4.14.5. Check the vendor advisory for mitigations.
References
- https://github.com/labring/FastGPT/commit/0beb52a2f3dc4067aab011cc98122d1352823b0c
- https://github.com/labring/FastGPT/releases/tag/v4.14.5-fix
- https://github.com/labring/FastGPT/security/advisories/GHSA-wcrg-g824-9gfg
Get alerted when CVE-2026-26003 or the next vulnerability affects your stack