What’s Vulnerable › Vulnerabilities
CVE-2026-26008: EVerest has OOB via EVSE ID Indexing Mismatch in OCPP 2.0.1 UpdateAllowedEnergyTransferModes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-125
Description
EVerest is an EV charging software stack. Versions prior to 2026.02.0 have an out-of-bounds access (std::vector) that leads to possible remote crash/memory corruption. This is because the CSMS sends UpdateAllowedEnergyTransferModes over the network. Version 2026.2.0 contains a patch.
Affected products
- everest-core: before 2026.02.0 — fixed in 2026.02.0
How to fix
Upgrade to a fixed version: everest-core 2026.02.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-26008 or the next vulnerability affects your stack