What’s Vulnerable › Vulnerabilities
CVE-2026-26015: Unauthenticated RCE in DocsGPT MCP STDIO Configuration
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-29 · updated 2026-10-26
- Weakness: CWE-77
Description
DocsGPT is a GPT-powered chat for documentation. From version 0.15.0 to before version 0.16.0, an attacker accessing both the official DocsGPT website or any local and public deployment, can craft a malicious payload bypassing the "MCP test" behavior to achieve arbitrary remote code execution (RCE). This issue has been patched in version 0.16.0.
Affected products
- arc53 DocsGPT: 0.15.0
References
- https://github.com/arc53/DocsGPT/releases/tag/0.16.0
- https://github.com/arc53/DocsGPT/security/advisories/GHSA-gcrq-f296-2j74
- https://www.ox.security/blog/mcp-supply-chain-advisory-rce-vulnerabilities-across-the-ai-ecosystem/
- https://www.ox.security/blog/the-mother-of-all-ai-supply-chains-critical-systemic-vulnerability-at-the-core-of-the-mcp/
- https://github.com/arc53/DocsGPT/security/advisories/GHSA-gcrq-f296-2j74
Get alerted when CVE-2026-26015 or the next vulnerability affects your stack