What’s Vulnerable › Vulnerabilities
CVE-2026-26020: AutoGPT Affected by Remote Code Execution via Dynamic Module Import in Block Loading (__import__)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-12 · updated 2026-06-17
- Weakness: CWE-285
Description
AutoGPT is a platform that allows users to create, deploy, and manage continuous artificial intelligence agents that automate complex workflows. Prior to 0.6.48, an authenticated user could achieve Remote Code Execution (RCE) on the backend server by embedding a disabled block inside a graph. The BlockInstallationBlock — a development tool capable of writing and importing arbitrary Python code — was marked disabled=True, but graph validation did not enforce this flag. This allowed any authenticated user to bypass the restriction by including the block as a node in a graph, rather than calling the block's execution endpoint directly (which did enforce the flag). This vulnerability is fixed in 0.6.48.
Affected products
- Significant-Gravitas AutoGPT: before 0.6.48 — fixed in 0.6.48
How to fix
Upgrade to a fixed version: Significant-Gravitas AutoGPT 0.6.48. Check the vendor advisory for mitigations.
References
- https://github.com/Significant-Gravitas/AutoGPT/commit/062fe1aa709217136b896c8b950e0f04435afb32
- https://github.com/Significant-Gravitas/AutoGPT/releases/tag/autogpt-platform-beta-v0.6.48
- https://github.com/Significant-Gravitas/AutoGPT/security/advisories/GHSA-4crw-9p35-9x54
Get alerted when CVE-2026-26020 or the next vulnerability affects your stack