What’s Vulnerable › Vulnerabilities
CVE-2026-26022: Gogs: Stored XSS via data URI in issue comments
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Gogs is an open source self-hosted Git service. Prior to version 0.14.2, a stored cross-site scripting (XSS) vulnerability exists in the comment and issue description functionality. The application's HTML sanitizer explicitly allows data: URI schemes, enabling authenticated users to inject arbitrary JavaScript execution via malicious links. This issue has been patched in version 0.14.2.
Affected products
- gogs: before 0.14.2 — fixed in 0.14.2
How to fix
Upgrade to a fixed version: gogs 0.14.2. Check the vendor advisory for mitigations.
References
- https://github.com/gogs/gogs/commit/441c64d7bd8893b2f4e48660a8be3a7472e14291
- https://github.com/gogs/gogs/pull/8174
- https://github.com/gogs/gogs/releases/tag/v0.14.2
- https://github.com/gogs/gogs/security/advisories/GHSA-xrcr-gmf5-2r8j
Get alerted when CVE-2026-26022 or the next vulnerability affects your stack